Identified
We are reworking our data pipeline due to a Snowflake behaviour change resulting in ineffective query execution and delayed data.
Investigating
Some customers' data has not yet synced to SELECT for the overnight runs. We are investigating.