Snowflake support has confirmed that this is an issue with a configuration change on the following views:
cortex_functions_query_usage_history
cortex_document_processing_usage_history
cortex_aisql_usage_history
cortex_search_daily_usage_history
cortex_search_serving_usage_history
Snowflake support has escalated this to their engineering team internally to investigate a possible regression. We are waiting on Snowflake to deploy a fix or rollback. The cortex sync currently blocks all metadata sync.
Monitoring
Snowflake support has confirmed that this is an issue with a configuration change on the following views:
cortex_functions_query_usage_history
cortex_document_processing_usage_history
cortex_aisql_usage_history
cortex_search_daily_usage_history
cortex_search_serving_usage_history
Snowflake support has escalated this to their engineering team internally to investigate a possible regression. We are waiting on Snowflake to deploy a fix or rollback. The cortex sync currently blocks all metadata sync.
Investigating
Some customers may experience delayed data in SELECT today due to a Snowflake platform issue affecting access to certain Cortex usage views. We are actively working with Snowflake support to resolve this and expect data pipelines to resume normally once the issue is addressed. The cortex sync currently blocks all metadata sync.