Resolved
Snowflake have resolved the underlying problem and syncs succeeded overnight.
Investigating
Multiple Snowflake account usage views are unable to be queried right now due to an error "Schema 'SNOWHOUSE_LOCAL.DS_USAGE.BILLING' does not exist or not authorized.". This is an internal Snowflake issue, we are monitoring the situation.
Syncs will be delayed until the underlying issue is resolved by Snowflake.