Resolved
Issue has been resolved. We apologies for the inconvenience caused.
Identified
We have identified the issue causing the filters to show "Not Set". We are in the process of rolling out a fix, which should be deployed within 30 minutes.
Investigating
Filters throughout the app are incorrectly rendering values as 'Not Set'. The team are actively working on resolving this issue, and the estimated time to fix is half an hour.